Login | Register
My pages Projects Community openCollabNet

Discussions > users > Re: [argouml-users] slashes in names of objects in collaboration diagrams

argouml
Discussion topic

Back to topic list

Re: [argouml-users] slashes in names of objects in collaboration diagrams

Author Alex Bagehot <A dot S dot P dot Bagehot at hw dot ac dot uk>
Full name Alex Bagehot <A dot S dot P dot Bagehot at hw dot ac dot uk>
Date 2002-07-22 12:01:13 PDT
Message Hi,

> > 2) Why is a slash, '/' always pre-pended to my object names?

To start with the current Argo collaboration diagrams create
classifier roles and not objects. They are effectively the
specification level diagrams described on page 3-105 of the UML1.3
spec. ( Instance level diagrams deal with objects etc.)

So:

Why is a slash, '/' always pre-pended to my classifier role names?

It's the notation that is defined in the UML1.3 specification. If you
don't have it, you can find it here:

http://www.omg.org/c​gi-bin/doc?formal/00​-03-01

You'll find on page 3-116 (page 362 in the pdf) of the Notation guide
two tables showing the syntax for objects and classifier role names.

argo currently uses the 3rd variant:

/R:C - a role name R with a base Class C

which brings me on to your other question.

> > 1) How can I use classes from my class diagrams in my
> collaboration
> > diagrams?

The only feature that you can re-use from your class diagrams is the
name of the classes you create. It's a bit limiting because you really
need to be able to reuse the operation names and associations as well
when you create messages between classifier roles. Any classes you
create ( in a class diagram) should appear in the 'base' drop down
menu on a classifier role's property panel. Ie. each classifier role
you create has a 'base Class'.

cheers,

Alex

On Mon, 22 Jul 2002 19:30:46 +0200 (CEST), Jaap Branderhorst
<jaap.branderhors​t@xs4all.nl> wrote:

> 1) At the moment you cannot :( We are working on it though
> 2) I have noticed that too. Will have a look if it is
> compliant to the UML
> spec (doubt it). Please make a bug report.
> Kind regards,
>
> Jaap Branderhorst
>
>
> > Hi All,
> >
> > I am using v0.10 and trying to build collaboration diagrams.
> I have a
> > couple of questions.
> >
> > 1) How can I use classes from my class diagrams in my
> collaboration
> > diagrams?
> >
> > 2) Why is a slash, '/' always pre-pended to my object names?
> >
> > Thanks,
> > John Black
>
>
>
>
>
--------------------​--------------------​--------------------​---------
> To unsubscribe, e-mail: users-unsubscribe@ar​gouml.tigris.org
> For additional commands, e-mail: users-help at argouml dot tigris dot org
>
>

____________________​____________________​____________________​____

DISCLAIMER:

This e-mail and any files transmitted with it are confidential
and intended solely for the use of the individual or entity to
whom it is addressed. If you are not the intended recipient
you are prohibited from using any of the information contained
in this e-mail. In such a case, please destroy all copies in
your possession and notify the sender by reply e-mail. Heriot
Watt University does not accept liability or responsibility
for changes made to this e-mail after it was sent, or for
viruses transmitted through this e-mail. Opinions, comments,
conclusions and other information in this e-mail that do not
relate to the official business of Heriot Watt University are
not endorsed by it.
____________________​____________________​____________________​____

--------------------​--------------------​--------------------​---------
To unsubscribe, e-mail: users-unsubscribe@ar​gouml.tigris.org
For additional commands, e-mail: users-help at argouml dot tigris dot org

« Previous message in topic | 1 of 13 | Next message in topic »

Messages

Show all messages in topic

Re: [argouml-users] slashes in names of objects in collaboration diagrams Alex Bagehot <A dot S dot P dot Bagehot at hw dot ac dot uk> Alex Bagehot <A dot S dot P dot Bagehot at hw dot ac dot uk> 2002-07-22 12:01:13 PDT
     Re: [argouml-users] slashes in names of objects in collaboration diagrams kataka Jaap Branderhorst 2002-07-22 12:19:46 PDT
         [argouml-users] Using Argo on MacOS X jim_evart jim hopper 2002-08-19 11:50:56 PDT
             Re: [argouml-users] Using Argo on MacOS X just4look Xue-Feng Yang 2002-08-19 12:05:09 PDT
                 Re: [argouml-users] Using Argo on MacOS X jim_evart jim hopper 2002-08-19 12:14:23 PDT
                     Re: [argouml-users] Using Argo on MacOS X just4look Xue-Feng Yang 2002-08-19 12:30:00 PDT
                         Re: [argouml-users] Using Argo on MacOS X jim_evart jim hopper 2002-08-19 13:02:58 PDT
                         Re: [argouml-users] Using Argo on MacOS X A dot S dot P dot Bagehot at hw dot ac dot uk A dot S dot P dot Bagehot at hw dot ac dot uk 2002-08-19 13:17:40 PDT
                             Re: [argouml-users] Using Argo on MacOS X jim_evart jim hopper 2002-08-19 13:26:26 PDT
                             [argouml-users] adding comments to look and feel bug jim_evart jim hopper 2002-08-19 13:30:58 PDT
                             Re: [argouml-users] Using Argo on MacOS X jim_evart jim hopper 2002-08-19 20:10:32 PDT
                         Re: [argouml-users] Using Argo on MacOS X jim_evart jim hopper 2002-08-19 13:20:46 PDT
                 Re: [argouml-users] Using Argo on MacOS X kataka Jaap Branderhorst 2002-08-19 12:16:49 PDT
Messages per page: