Hi:

Here is my story. I have downloaded the ArgoUML 0.14 src code. I built it and able to run it without any problems.

It comes with a i18n.jar file. I need to customize some code in that. So how can I get the correct source code of i18n module which is compatible with Argo 0.14?

 

By the way I downloaded the i18n source version of 0.1.3 from workingfrog.org. I was able to build that but when I replaced the original i18n.jar (which came from argo download) with this one, I get the following exception

 

  [argouml] java.lang.NullPointerException

  [argouml]     at org.workingfrog.i18n.util.Localizer.localize(Localizer.java:1

25)

  [argouml]     at org.workingfrog.i18n.util.Validator.checkValue(Validator.java

:175)

  [argouml]     at org.workingfrog.i18n.util.Validator.check(Validator.java:97)

  [argouml]     at org.workingfrog.i18n.util.Translator.localize(Translator.java

:132)

  [argouml]     at org.workingfrog.i18n.util.Translator.checkValue(Translator.ja

va:160)

  [argouml]     at org.workingfrog.i18n.swing.I18NJFrame.setTitle(I18NJFrame.jav

a:80)

  [argouml]     at org.argouml.ui.ProjectBrowser.setTitle(ProjectBrowser.java:43

7)

  [argouml]     at org.workingfrog.i18n.swing.I18NJFrame.<init>(I18NJFrame.java:

68)

  [argouml]     at org.workingfrog.i18n.swing.I18NJFrame.<init>(I18NJFrame.java:

63)

  [argouml]     at org.argouml.ui.ProjectBrowser.<init>(ProjectBrowser.java:180)

 

  [argouml]     at org.argouml.ui.ProjectBrowser.getInstance(ProjectBrowser.java

:990)

  [argouml]     at org.argouml.application.Main.initializeGUI(Main.java:427)

  [argouml]     at org.argouml.application.Main.main(Main.java:198)

  [argouml] Exception in thread "main"  

 

 

Any help would be greatly appreciated.

 

Regards

--Deb